VLC 3 on Linux Mint 18

Created at 2018-08-28 Updated at 2018-08-28 Tag Linux Mint / VLC

TL;DR

If you want to listen to ad-free Chillstep with Linux Mint 18.3, you will need to install VLC 3, and here is how you can do that with a Snap:

1
2
sudo apt install snapd
sudo snap install vlc

The Rest of the Story

I'll admit, not much of a first post, but I have to start somewhere.

Ok, so here's the scoop; I have Linux Mint 18.3 installed, and I would like to listen to some Chillstep on YouTube while I'm working, but without the interruption of ads.

So, easy, just need to open up VLC, and then open a network stream:

After that I can enjoy the music, right? Wrong.

Unfortunately with VLC 2.2.2, the default version install on Linux Mint 18.3, I get this error:

Your input can't be opened:
VLC is unable to open the MRL ‘https://…

What this means is that YouTube is forcing https (good thing) on all of their connections. However, VLC's “Network Stream” option does not like that…until version 3.

Alright, now I just need to install VLC 3. Yet another unfortunate turn, as the "Videolan" team PPA does not provide VLC version 3.

The Solution

I am fairly new to Sanps, Flatpaks, AppImages, etc,. Regardless, I decided to give Snaps a shot, and here is how you install VLC 3 with a Snap on Linux Mint 18.3:

1
2
sudo apt install snapd
sudo snap install vlc

After that install completes, you will have the Snap with VLC 3 installed as well as the original VLC that came with Linux Mint 18.3 (2.2.2):

Now just repeat my steps above to “Open Network Stream…”, but this time with your newly installed VLC 3, and you'll be listening to your ad-free chillstep in no time.

Hope you found this helpful, and if you have any questions, please comment below.

Site by Aaron von Awesome using Hexo & Random